Reactor Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 6
Number of dependencies (NOD): 91
Number of unique artifacts (NOA): 99
Number of version-conflicting artifacts (NOC): 7
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 91 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in modules

com.sun.enterprise:config-types

[Error]
1.0.25
  1. net.sf.jkniv:jkniv-jaas-glassfish:jar:0.1.0
    \- org.glassfish.security:security:jar:3.1.1:provided
       \- org.glassfish.admin:config-api:jar:3.1.1:provided
          \- com.sun.grizzly:grizzly-config:jar:1.9.36:provided
             \- (com.sun.enterprise:config-types:jar:1.0.25:provided - omitted for conflict with 1.1.6)

1.1.6
  1. net.sf.jkniv:jkniv-jaas-glassfish:jar:0.1.0
    \- org.glassfish.security:security:jar:3.1.1:provided
       \- org.glassfish.common:glassfish-api:jar:3.1.1:provided
          \- com.sun.enterprise:config-types:jar:1.1.6:provided

com.sun.enterprise:hk2

[Error]
1.0.25
  1. net.sf.jkniv:jkniv-jaas-glassfish:jar:0.1.0
    \- org.glassfish.security:security:jar:3.1.1:provided
       \- org.glassfish.admin:config-api:jar:3.1.1:provided
          \- com.sun.grizzly:grizzly-config:jar:1.9.36:provided
             \- (com.sun.enterprise:hk2:jar:1.0.25:provided - omitted for conflict with 1.1.6)

1.1.6
  1. net.sf.jkniv:jkniv-jaas-glassfish:jar:0.1.0
    \- org.glassfish.security:security:jar:3.1.1:provided
       +- com.sun.enterprise:hk2:jar:1.1.6:provided
       +- org.glassfish.admin:config-api:jar:3.1.1:provided
       |  \- (com.sun.enterprise:hk2:jar:1.1.6:provided - omitted for duplicate)
       +- org.glassfish.deployment:dol:jar:3.1.1:provided
       |  +- (com.sun.enterprise:hk2:jar:1.1.6:provided - omitted for duplicate)
       |  \- org.glassfish.common:annotation-framework:jar:3.1.1:provided
       |     \- (com.sun.enterprise:hk2:jar:1.1.6:provided - omitted for duplicate)
       +- org.glassfish.common:common-util:jar:3.1.1:provided
       |  \- (com.sun.enterprise:hk2:jar:1.1.6:provided - omitted for duplicate)
       +- org.glassfish.security:ssl-impl:jar:3.1.1:provided
       |  \- (com.sun.enterprise:hk2:jar:1.1.6:provided - omitted for duplicate)
       +- org.glassfish.deployment:deployment-common:jar:3.1.1:provided
       |  \- (com.sun.enterprise:hk2:jar:1.1.6:provided - omitted for duplicate)
       +- org.glassfish.common:internal-api:jar:3.1.1:provided
       |  \- (com.sun.enterprise:hk2:jar:1.1.6:provided - omitted for duplicate)
       +- org.glassfish.common:glassfish-api:jar:3.1.1:provided
       |  \- (com.sun.enterprise:hk2:jar:1.1.6:provided - omitted for duplicate)
       +- org.glassfish.ejb:ejb-internal-api:jar:3.1.1:provided
       |  \- (com.sun.enterprise:hk2:jar:1.1.6:provided - omitted for duplicate)
       \- org.glassfish.connectors:connectors-internal-api:jar:3.1.1:provided
          +- (com.sun.enterprise:hk2:jar:1.1.6:provided - omitted for duplicate)
          \- org.glassfish.transaction:transaction-internal-api:jar:3.1.1:provided
             \- (com.sun.enterprise:hk2:jar:1.1.6:provided - omitted for duplicate)

com.sun.enterprise:hk2-core

[Error]
1.0.25
  1. net.sf.jkniv:jkniv-jaas-glassfish:jar:0.1.0
    \- org.glassfish.security:security:jar:3.1.1:provided
       \- org.glassfish.admin:config-api:jar:3.1.1:provided
          \- com.sun.grizzly:grizzly-config:jar:1.9.36:provided
             \- com.sun.enterprise:osgi-adapter:jar:1.0.25:provided
                \- (com.sun.enterprise:hk2-core:jar:1.0.25:provided - omitted for conflict with 1.1.6)

1.1.6
  1. net.sf.jkniv:jkniv-jaas-glassfish:jar:0.1.0
    \- org.glassfish.security:security:jar:3.1.1:provided
       \- com.sun.enterprise:hk2:jar:1.1.6:provided
          \- com.sun.enterprise:hk2-core:jar:1.1.6:provided

junit:junit

[Error]
4.11
  1. net.sf.jkniv:jkniv-jaas-glassfish:jar:0.1.0
    \- junit:junit:jar:4.11:test

4.3.1
  1. net.sf.jkniv:jkniv-jaas-glassfish:jar:0.1.0
    \- org.glassfish.security:security:jar:3.1.1:provided
       \- com.sun.enterprise:hk2:jar:1.1.6:provided
          \- com.sun.enterprise:hk2-core:jar:1.1.6:provided
             \- org.glassfish.hk2:class-model:jar:1.1.6:provided
                \- (junit:junit:jar:4.3.1:provided - omitted for conflict with 4.11)

log4j:log4j

[Error]
1.2.16
  1. net.sf.jkniv:jkniv-whinstone-jdbc:jar:0.6.0.RC1-SNAPSHOT
    \- log4j:log4j:jar:1.2.16:test

1.2.17
  1. net.sf.jkniv:jkniv-whinstone-jdbc:jar:0.6.0.RC1-SNAPSHOT
    \- org.slf4j:slf4j-log4j12:jar:1.7.7:test
       \- (log4j:log4j:jar:1.2.17:test - omitted for conflict with 1.2.16)

org.glassfish.external:management-api

[Error]
3.0.0-b012
  1. net.sf.jkniv:jkniv-jaas-glassfish:jar:0.1.0
    \- org.glassfish.security:security:jar:3.1.1:provided
       \- org.glassfish.gmbal:gmbal:jar:3.1.0-b001:provided
          \- (org.glassfish.external:management-api:jar:3.0.0-b012:provided - omitted for conflict with 3.1.0-b001)

3.1.0-b001
  1. net.sf.jkniv:jkniv-jaas-glassfish:jar:0.1.0
    \- org.glassfish.security:security:jar:3.1.1:provided
       +- org.glassfish.deployment:deployment-common:jar:3.1.1:provided
       |  \- (org.glassfish.external:management-api:jar:3.1.0-b001:provided - omitted for duplicate)
       +- org.glassfish.common:glassfish-api:jar:3.1.1:provided
       |  \- (org.glassfish.external:management-api:jar:3.1.0-b001:provided - omitted for duplicate)
       \- org.glassfish.external:management-api:jar:3.1.0-b001:provided

org.slf4j:slf4j-api

[Error]
1.7.21
  1. net.sf.jkniv:jkniv-sqlegance:jar:0.6.0.RC1-SNAPSHOT
    +- net.sf.jkniv:jkniv-utils:jar:0.6.0.RC1-SNAPSHOT:compile
    |  \- (org.slf4j:slf4j-api:jar:1.7.21:compile - omitted for duplicate)
    \- org.slf4j:slf4j-api:jar:1.7.21:compile

  2. net.sf.jkniv:jkniv-utils:jar:0.6.0.RC1-SNAPSHOT
    \- org.slf4j:slf4j-api:jar:1.7.21:compile

  3. net.sf.jkniv:jkniv-whinstone-jdbc:jar:0.6.0.RC1-SNAPSHOT
    +- net.sf.jkniv:jkniv-sqlegance:jar:0.6.0.RC1-SNAPSHOT:compile
    |  \- (org.slf4j:slf4j-api:jar:1.7.21:compile - omitted for duplicate)
    +- net.sf.jkniv:jkniv-utils:jar:0.6.0.RC1-SNAPSHOT:compile
    |  \- (org.slf4j:slf4j-api:jar:1.7.21:compile - omitted for duplicate)
    \- org.slf4j:slf4j-api:jar:1.7.21:compile

  4. net.sf.jkniv:jkniv:pom:0.6.0.RC1-SNAPSHOT
    \- org.slf4j:slf4j-api:jar:1.7.21:compile

1.7.7
  1. net.sf.jkniv:jkniv-sqlegance:jar:0.6.0.RC1-SNAPSHOT
    \- org.slf4j:slf4j-log4j12:jar:1.7.7:test
       \- (org.slf4j:slf4j-api:jar:1.7.7:test - omitted for conflict with 1.7.21)

  2. net.sf.jkniv:jkniv-utils:jar:0.6.0.RC1-SNAPSHOT
    \- org.slf4j:slf4j-log4j12:jar:1.7.7:test
       \- (org.slf4j:slf4j-api:jar:1.7.7:test - omitted for conflict with 1.7.21)

  3. net.sf.jkniv:jkniv-whinstone-jdbc:jar:0.6.0.RC1-SNAPSHOT
    +- org.postgresql:postgresql:jar:9.4-1200-jdbc41:test
    |  +- com.github.dblock.waffle:waffle-jna:jar:1.7:test
    |  |  \- (org.slf4j:slf4j-api:jar:1.7.7:test - omitted for conflict with 1.7.21)
    |  \- org.slf4j:slf4j-simple:jar:1.7.7:test
    |     \- (org.slf4j:slf4j-api:jar:1.7.7:test - omitted for conflict with 1.7.21)
    \- org.slf4j:slf4j-log4j12:jar:1.7.7:test
       \- (org.slf4j:slf4j-api:jar:1.7.7:test - omitted for conflict with 1.7.21)

  4. net.sf.jkniv:jkniv:pom:0.6.0.RC1-SNAPSHOT
    \- org.slf4j:slf4j-log4j12:jar:1.7.7:test
       \- (org.slf4j:slf4j-api:jar:1.7.7:test - omitted for conflict with 1.7.21)